444 GAMES
   1,160 MEMBERS
   22 TUTORIALS
   115 DEV LOGS
Forgot your password? Click here


Ads working again!


Posted: 2020-04-03 17:54:18 |    Posted by iDev |    idevgames.co.uk

1
Login to like

So I don't really have a clue why. Somehow a script that is needed for the ad pages started bringing back a 304 forbidden error. Breaking the play button on the ads, which stopped players from playing the games. I'm not sure when this began but a few days ago I noticed it had stopped working, after trouble shooting I found it was working on some browsers and I couldn't understand why or how but I put it down as an isolated issue as I knew it was working for other people.

Then today I started looking into it and found out it wasn't an isolated issue. So now I have re-coded the ad pages so they are working again. Also the best part is that it now retrieves the url instantly instead of contacting another script. As sometimes if you clicked the play button too fast it wouldn't do anything, due to having to contact another script to retrieve the url.

If you ever run into any problems like this on the site. Please contact me through twitter @HTML5Arcade so I can fix problems like this quicker. I'm also sorry for any inconvenience this may have caused. Problems can sometimes happen and hopefully we won't have something like this happen again.

Also as a bit of a positive, I have also done some bug fixes on the site over the past month or so. The best part was the addition of image uploads in the posts and games pages content. This used to be possible but broke with the rebuild. Though this time it's working better then before. It will upload the image instead of saving a blob image in the database (which really weighs down the database). Also converts the images to webp! So all the images on the site are as quick as they can be.

 

Thanks,

-iDev

Would you like to comment on this post? Create an account in less then 1 minute Click here



Back to top